Search This Blog

Tuesday, May 31, 2011

Plasma NM: bugs fixed after 4.6.3

Well, the number of crashes is decreasing, that is a good signal :-)

Following my last post about bugs fixed in Plasma NM, here is the list of bugs fixed between 4.6.3 release date (May 6th) and 4.6.4 release date (June 10th):

. Fix NM version number check.
. Always shows the "Create connection" button in the interface added notification for modem interfaces. Until now it was only shown when there was no modem connection.
275163: Fix changing adapter display type disables networking system
275159: Disables "Show More" button instead of hidding it if there is no wireless interface available.
275160: Defaults to wired tab in ManageConnectionWidgets if wireless is disabled.
274702 275161:  Try to prevent opening kwallet when there is no secret to retrieve.
274797: Set right widget's width to fixed size to prevent unneeded graphical layout resizes.
146159 182984: Import VPN connections from configuration files. Only VPNC is implemented so far, but the hooks for other VPN types are in place now.
. Fix initial default route icon's state when starting kded module and a connection is already active.
274860: Change networkmanagement_shell into a singleton to prevent calling the edit connection dialog multiple times.
274859: Disable "Low signal strength" notification by default and increase the interval between "Low signal strenght" notifications to 5 minutes.
274846:  Backport fix for disconnecting auto-connect connections when compiled against Solid < 4.7.0.
. Fix some issues when entering wireless channel manually instead of using the spinbox buttons.
. Add text in main window to warn when using Plasma NM with wrong NM version.
274161: Prevents crash when configuring 3G modem.
273894: Prevent crashes when closing kcmshell too fast after closing the connection editor.
. Fix two crashes when editing IPv4 config.
273955: Prevents dangling pointer crash.
266268: Try to adjust plasmoid size automatically.
273265: Fix crash on editing connections in KCM module.
. Update main CMakeLists.txt file to indicate that now we need at least NetworkManager-0.8.1. That is because of the IPv6 implementation, which first appeared in 0.8.1.
. Fix UUID check for DUN and NAP services in networkmanagement_configshell which prevented adding new Bluetooth connections.
272942: Change the automatic launching of Mobile Connection Wizard into a notification.
157384: Allow automatically set connection's BSSID to the BSSID of the AP selected in scanwidget.
272841: Fix crash when clicking on the VPN interface.
254155: Prevent graphical artifact during tab transition in m_interfaceDetailsWidget.
228298: Show correct WEP key type (Passphrase/Hex) when editing/showing connection secrets.
272774: Wrap interface label in InterfaceItem class, now only the first line is displayed.
. Several memory leak fixes.


Anonymous said...

It's so awesome that you fix all those bugs. There once was the feeling that the network manager plugin is kind of unmaintained. But reading this blogs I get the impression that the current state is getting better and better :-) Keep it up!

Lamarque said...

Well, I did not fixed all of those bugs, just about 2/3 of them. The other were fixed by Ilia Kats and Montel Laurent. There were a time very few things were happening in Plasma NM, Ilia Kats and I are trying to change that. We have achieved several interesting things this year, but there are still things to implement and bugs to fix. Thanks for the support.

Einar said...

Perhaps it's a stupid request, but once the NM 0.9 work is more or less done, would it be possible to slap a version number on PNM and do an official release? Despite its wide use in KDE distros, it has never seen a single "stable" release (even though it works perfectly for me). It's not a fault, just "PR".

Lamarque said...

Plasma NM is still in constant development because we still have some missing and other half-implemented features, and we still need to re-organize the code and do some other changes to be accepted in KDE SC (Plasma NM is in KDE Extragear now).

I want to have a version number based on NM version we support, but the current version for NM-0.8 already uses 0.9 as version number in some distributions. We need to work this out indeed.